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Document information 

a. Document’s version history 
 

Version Date Description Auteur 

2.1 25/06/2021 Translation from FR version AC 

 

b. Disclaimer 
The information contained in this document is subject to change without warning and does not represent a 

commitment on the part of ATIM radiocommunications. ATIM radiocommunications provides this document ‘as-is’ 

with no warranty of any kind, express or implied, including but not limited to implied warranties of merchantability or 

fitness for a particular purpose. ATIM radiocommunications may make changes and/or improvements to this manual 

or to the product(s) or program(s) described in this manual, at any time. 

 

App versions  

Here is a rapid overview of the major updates according to the application version. 

Version Description 

v5.0.x Support for the new generation product + add BLE (Bluetooth Low Energy) 

capability 

5.1.x Single application for every ATIM products. 

 

  



4 

ATIM_ACW-CFG_UG_EN_V2.1 

Configuration of an ACW device 

Several methods are available to configure an ACW device. 

a. USB connection 
The easiest way to configure an ACW device is by using a USB cable (refer to the product’s user guide for more details 

on how to connect the USB cable to the product). After launching the ACW Configurator app, wait few seconds for the 

configuration page to load. 

Here is an example of what you would see after connecting a Sigfox version of an ACW-TH: 

Image 1 – Sigfox version of an ACW-TH configuration page 

At the top of the window, the general information of the device is displayed like its product reference , a brief 

overview , the radio technology  used and an image of the product. 

In the bottom left corner  , are the software version of the ACW device, name and software version of the radio 

module and the network ID (Sigfox ID for Sigfox devices or devEUI for LoRAWAN ones).  

 

NOTE 
In some cases, especially for LoRAWAN device, the devEUI is not correctly displayed only the 4 least significant bytes are. For 
every ATIM devices the 4 most significant bytes are: 70B3D59B. 

 

 

1 
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In the bottom right corner, you will find three control buttons  to respectively reload and apply the factory 

parameters ( ), to update the configuration page with the configuration from the ACW device (

) and to apply the configuration from the configuration page to the ACW device ( ).  

These control buttons are also available from the  menu. 

Image 2 – Edit menu (ACW controls)  

The rest of the window is relative to the ACW device itself and holds all the possible configuration parameters. 

 

NOTE 
Once you are done with the done with the configuration of the parameters you should imperatively click on the 

  button for the configuration to be loaded to the ACW device. 
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b. Bluetooth connection 
From the v5.0.X version, the app allows to connect to an ACW device using Bluetooth (if the product itself support it, 

refer to the product user guide for this part) for its configuration. 

Once an ACW device is discoverable, it will be displayed in a list view as it is shown below with a ACW-MR4 and a ACW 

TMxP. 

To connect to an ACW, choose a device among the list and 

click “Connect”. The configuration page of the product will 

be automatically loaded after a few seconds. 

 

NOTE 
The configuration page is noticeably the same compared to the 
one for a ISB connection except the “Close” button (on the top 
right corner) to allow closing the connection with the device. 

 

 

c. Configuration file (.acf) 
It is possible to save locally in a file (with a ".acf" extension) the configuration parameters of an ACW. This 

functionality allows to save a specific configuration and use later on to configure a bunch of device. You can also 

see the Auto configuration section that uses this type of file. 

 

d. With an ACW connected 
 With an ACW connected, you can either choose to save its current configuration to a file or to load and apply a 

configuration from a file.  

 

WARNING 

Do not forget to click on     after loading a configuration file to effectively apply the new configuration to the 
device.  

Opening and saving a configuration is accessible through the  menu. Opening a file is possible from the menu « 

File->Open... », saving a new file from the menu « File->Save As » or saving to an existing one (overwriting it) from the 

menu « File->Save ». 
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Image 3 -File menu (Opening/Saving) 

To notify opening or saving is successful or not, a message is displayed for three seconds on the bottom left corner of 

the page. 

e. Offline mode (ACW not connected) 
Configuration files are particularly useful in offline mode (no ACW connected to the APP) to prepare and save a 

configuration file. 

From an existing file 

Loading an existing file is possible from the menu « File->Open... » or « File->Recent Files » with a list of the latest files 

saved. 

Image 4 -File menu (Opening a file) 

The configuration interface will load automatically afterwards. You will then be able to modify the configuration 

parameter of the ACW from the loaded file. The interface is the same as for USB or Bluetooth connection, unlike 

control buttons and version numbers. 
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As an example, here is the page loaded for an ACW-DINDIO16 (LoRAWAN version):  

Image 5 - Interface d’un ACW-DINDIO16 en LoRAWAN 

In the bottom left corner , only the ACW software version and the radio module are displayed, with the value 

stored in the configuration file.  

In the bottom right corner, are still the control buttons  to respectively quit and close the configuration page (

), reload the configuration from the file ( ) and save to the previously opened file (

).  

1 

2 

1 
2 
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From the ACW selector 

On the right side of the Home page, you can choose an ACW based on its name, technology, and version number.  

For example, by focusing on an ACW-TMxD (ACW-TM1D or ACW-TM2D) from the list: 

Image 6 - ACW-TMxD 

   

Once your product is identified, you will need to select the radio technology of your device and the version number. 

The 'Reference' field corresponds to the commercial reference that is adjusted according to your selection. Once your 

selection is made, click on the button , the configuration page is automatically loaded with the default 

settings. The interface is then used as if you had loaded a file. Refer to the From an existing file chapter. 

 Depending on the ACW, one or more technologies will be available. The following technologies may be available: 

1. Sigfox (uplink only): Sigfox version that does not benefit from the downlink. This is especially the case for 

rather old devices. If you have any doubt about the technology of your ACW, preferably select "Sigfox 

(downlink)". 

2. Sigfox (downlink): Full Sigfox version. 

3. LoRAWAN: LoRAWAN version. 

4. Sigfox (Worldwide): Sigfox version with worldwide capability. 
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Depending on the technology, some settings will not be available. For example, in LoRAWAN, the parameter of the 

pairing method (ABP or OTAA) which does not exist in Sigfox.  

So, it's important to select the right technology the device is using.  

 

NOTE 
If you try to load a configuration file into an ACW that does not match the correct technology, an alert message will be opened 
to avoid the process to be completed. 

 

The choice of version number is equally important. In the same way, parameters can be added from one version of an 

ACW to another (the description may change accordingly). The configurator does not offer the selection of all version 

numbers, only versions affected by major updates on the configuration side are available. You will therefore need to 

select the highest proposed version number without exceeding the version number of your ACW.  

For example, if the configurator offers you the following versions v1.2.3, v2.4.1, v3.3.3 and v6.4.2 and you have version 

v2.9.5 you will have to select v2.4.1.  
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Exporting and importing downlink frames 

Configuration frames can be imported or exported. You can therefore generate frames to configure a device using 

Downlink or retrieve the remote configuration of a device (after sending a specific downlink command) and verify it 

by importing the frames. 

To use these functions, you must either connect an ACW in USB/BLE, open a configuration file or select a device from 

the list on the Home page of the configurator. 

a. Export 
 The export function is accessible from the "Edit->Export frames" menu. 

Image 7 – Edit menu (Export frames) 

A new window opens with a list of parameters that depends on the ACW. For example, for a DINDIO16 in LoRAWAN, 

the window looks like the one below:  

Image 8 - Export frames 

In the "View parameters" part  you can see in the "Parameters" column all the parameters available for the ACW. 

Each parameter is identified by a number and a short description. In the "Value" column, you will find the value that 

you probably previously changed from the configuration page.  

NOTE 
More information on the numbers and function of each parameter can be found in the ACW specific User guide. 

1 

1 2 

3 

4 5 6 
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In the "View Frames" part  is displayed the configuration frames that you can use to send them via Downlink. 

To create frames from the parameters, you will have to select the parameters you want and then click on the arrow  

 which will generate one or more frames to send in the view of the frames  

NOTE 
By right-clicking on the selected settings you also have access to this feature. 

For example, by selecting the parameters from 30 to 33 of the DINDIO16 LoRAWAN: 

Image 9 - Export frames (DINDIO16 parameters 30 to 33) 

You can change the maximum size of the frames with the "Max payload" selector   according to the constraints of 

your network and your contract. In addition, you can at any time recalculate the frames by clicking on the    

button. 

NOTE 
The "Max payload" field is predefined according to the technology of the ACW, i.e. 8 bytes in Sigfox and 36 bytes in LoRAWAN. 

To retrieve the generated frames, you will have to click on the button, displaying a menu that will offer you to copy all 

the frames "Export all frames to clipboard" or only the selected frames "Export selected frames to clipboard" in the 

clipboard. You will then just have to paste the result into a text document for example or directly into the platform 

that manages the Downlink of your product.  

NOTE 
By right-clicking on the selected frames you also have access to this feature. 

To see only the frames, you can fold or unfold the parameters by clicking on the arrow next to the frame, or on the 

arrows   at the bottom to affect all the frames. 
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To remove frames, you can select them and click arrow    To remove all frames you can also click the button.  

NOTE 
By right-clicking on the selected frames you also have access to these features. 

 

b. Import 
 The import function is accessible from the "Edit->Import frames" menu 

Image 10 - Edit menu (Import frames) 

 A new window opens with a visual inspired by the export tool (see export section). The window looks 

like the one below:  

Image 11 - Import frames 

To add a new frame, the frame must first have been copied to the clipboard. By clicking on the button , a menu 

offers you to import the frames from the clipboard. The frames and parameters will then be displayed following the 

same formalism as the export tool.  

NOTE 
By right-clicking on the selected frames you also have access to these features. 

 

3 
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As for the export function you can fold / unfold the parameters of the frames or delete all the frames. To apply the 

frames to the ACW (or file) that is commonly opened, you will only need to click on the button, the graphical interface 

will automatically update.  

 

NOTE 
Then remember to apply or save the new configuration. 

 

If you import frames sent by the ACW because of a configuration request Downlink (0104), all received frames starting 

with 0x0704, so you will first need to delete the first two bytes (0704) before importing them. 
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Auto-configuration tool 

After the configurator added support for configuration files, a configuration automation tool was integrated to 

configure multiple ACW from a configuration file in a row. This tool is only accessible with a USB connection. 

This tool is available from the "Tools->Auto Config" menu: 

Image 12 - Tool menu (Auto Config) 

The window that opens then looks like the one below: 

Image 13 - Auto Config tool 

In the bottom part  , an information message guides you on the operations to follow for a smooth running of the 

configurations. 

  

The first operation to do is to load a configuration file by clicking on the  button  , the path and name of the file 

is thus displayed and loaded. As a result of this, the commercial reference   of the product read from the file is also 

displayed in the top part of the window. In the example above a configuration file of an ACW-TMxD (TM1D or TM2D) 

in LoRAWAN version is loaded. 
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At this point the tool is ready to configure ACWs, so you can connect an ACW via USB. The configuration is 

automatically loaded and saved in the ACW. A message   is displayed proving the success or failure of the operation. 

This message displays the name and version number of the ACW and radio module, the Sigfox identifier or the 

LoRAWAN DevEUI is also displayed for each of the connected ACWs. In the screenshot above, 4 ACW-TM2D in 

LoRAWAN have been connected and configured. 

  

3 
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Product Update  

On new-generation ACW, it is possible to perform an update of the product software and the BLE module software via 

Bluetooth (not available via USB). 

To do this, you must first connect the ACW via Bluetooth to the configurator to access the ACW configuration page. 

The tool is then accessible from the "Tools ->Updater" menu: 

 

Image 14 Tools menu (Updater) 

The following window opens: 

 

Image 15 "Updater" Tool 

The procedure is identical to update the ARM-BLE or ACW and can be summarized as follows: 

• Open the update binary file on your computer by clicking  
• Check the Encrypted box 

• Once the file is loaded, start the update by clicking on  

A progress bar is present to indicate the progress of Update  and a console is used to display textual information 

throughout Update  
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Update help 
1. My product does not appear in the list of products detected in Bluetooth? 

Make sure Bluetooth is enabled on your computer. If the problem persists, exit the application, restart your computer's 

Bluetooth via Windows settings and then restart the PC application. 

1. The connection with the product is never established (message "connection in progress" indefinitely)? 

In some cases, the application may fail to establish the connection with the product. If after a few minutes, after 

initiating a connection request with the product, nothing happens, exit the application and restart it. 

1. The message "Atim Cloud Wireless Configuration is already running" appears when you try to launch the PC 

app? 

If this message appears, open the task manager (right click on the taskbar) and then look for the "acw_cfg.exe" line. 

Right-click on this line and click on "end task". Once the row has disappeared you can restart the application. 

1. During the update, the [ERROR] message is displayed. What to do? 

If this message appears, exit the update tool by clicking on "close tool". Once the product has been detected again by 

the application, repeat the procedure. 

If the product is not displayed, refer to the questions above. 

1. The product name in the Bluetooth Detected Product list does not match the name of my product 

("ARM_BLE v0.0.1" appears). 

In this case, you will still be able to connect to this product even if its name does not match its reference. By 

initiating a connection, you will find yourself directly on the product update page without going through its 

configuration page.  
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Technical support 

Contact our technical support team by email with any questions or technical problems you may have:  

https://www.atim.com/en/technical-support/ 

 

https://www.atim.com/en/technical-support/

